package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$`)
var str = []byte(`ashish.verma724@gmail.com
alok%#%$#%$#%$#%$%`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}