use strict;
my $str = 'ashish.verma724@gmail.com
alok%#%$#%$#%$#%$%';
my $regex = qr/^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";