re = /^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$/
str = 'ashish.verma724@gmail.com
alok%#%$#%$#%$#%$%'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result