const regex = /^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([_A-Za-z0-9-\\\\+]+(\\\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\\\.[A-Za-z0-9]+)*\\.[A-Za-z]{2,})$', '')
const str = `ashish.verma724@gmail.com
alok%#%\$#%\$#%\$#%\$%`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);