$re = '/^([_A-Za-z0-9-\\\\+]+(\\\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$/';
$str = 'ashish.verma724@gmail.com
alok%#%$#%$#%$#%$%';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;