#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$"
Local $sString = "ashish.verma724@gmail.com" & @CRLF & _
"" & @CRLF & _
"alok%#%$#%$#%$#%$%"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)