using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)*@[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*\.[A-Za-z]{2,})$";
string substitution = @"";
string input = @"ashish.verma724@gmail.com
alok%#%$#%$#%$#%$%";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}