#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^\w* ?regards,?"
Local $sString = "Hi There, this is an email. This email is " & @CRLF & _
"regarding my previous email that regards " & @CRLF & _
"many warm regards. " & @CRLF & _
"" & @CRLF & _
"Warm Regards," & @CRLF & _
"" & @CRLF & _
"Many regarDs," & @CRLF & _
"Regards," & @CRLF & _
"" & @CRLF & _
"Joe Bloggs"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")