$re = '/^\w* ?regards,?/im';
$str = 'Hi There, this is an email. This email is
regarding my previous email that regards
many warm regards.
Warm Regards,
Many regarDs,
Regards,
Joe Bloggs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);