re = /^\w* ?regards,?/im
str = 'Hi There, this is an email. This email is
regarding my previous email that regards
many warm regards.
Warm Regards,
Many regarDs,
Regards,
Joe Bloggs'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end