import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w* ?regards,?";
final String string = "Hi There, this is an email. This email is \n"
+ "regarding my previous email that regards \n"
+ "many warm regards. \n\n"
+ "Warm Regards,\n\n"
+ "Many regarDs,\n"
+ "Regards,\n\n"
+ "Joe Bloggs";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}