using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w* ?regards,?";
string input = @"Hi There, this is an email. This email is
regarding my previous email that regards
many warm regards.
Warm Regards,
Many regarDs,
Regards,
Joe Bloggs";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}