// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^\w* ?regards,?").unwrap();
let string = "Hi There, this is an email. This email is
regarding my previous email that regards
many warm regards.
Warm Regards,
Many regarDs,
Regards,
Joe Bloggs";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}