const regex = new RegExp('^\\w* ?regards,?', 'gim')
const str = `Hi There, this is an email. This email is
regarding my previous email that regards
many warm regards.
Warm Regards,
Many regarDs,
Regards,
Joe Bloggs`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}