package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^\w* ?regards,?`)
var str = `Hi There, this is an email. This email is
regarding my previous email that regards
many warm regards.
Warm Regards,
Many regarDs,
Regards,
Joe Bloggs`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}