#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)"
Local $sString = "http://google.com/abc" & @CRLF & _
"localhost/." & @CRLF & _
"localhost." & @CRLF & _
"localhost/" & @CRLF & _
"http://stackoverflow.com/questions/ask" & @CRLF & _
"google.com" & @CRLF & _
"" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984" & @CRLF & _
"" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s" & @CRLF & _
"" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453" & @CRLF & _
"" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/" & @CRLF & _
"" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something" & @CRLF & _
"" & @CRLF & _
"https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")