$re = '/(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)/m';
$str = 'http://google.com/abc
localhost/.
localhost.
localhost/
http://stackoverflow.com/questions/ask
google.com
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something
https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);