const regex = /(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\.org)((?:\\\/kr\\\/customer\\\/account\\\/forgotpassword\\\/)(\\?.+)?)|((?:\\\/partners\\\/boeing\\\/customer\\\/account\\\/forgotpassword\\\/)(\\?.+)?)(?:(?= )|$)', 'mg')
const str = `http://google.com/abc
localhost/.
localhost.
localhost/
http://stackoverflow.com/questions/ask
google.com
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something
https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}