re = /(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)/m
str = 'http://google.com/abc
localhost/.
localhost.
localhost/
http://stackoverflow.com/questions/ask
google.com
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something
https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end