import re
regex = re.compile(r"(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)", flags=re.MULTILINE)
test_str = ("http://google.com/abc\n"
"localhost/.\n"
"localhost.\n"
"localhost/\n"
"http://stackoverflow.com/questions/ask\n"
"google.com\n\n"
"https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984\n\n"
"https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s\n\n"
"https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/\n"
"https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453\n\n"
"https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/\n\n"
"https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something\n\n"
"https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")