import Foundation
let pattern = #"(?<=\.org)((?:\/kr\/customer\/account\/forgotpassword\/)(\?.+)?)|((?:\/partners\/boeing\/customer\/account\/forgotpassword\/)(\?.+)?)(?:(?= )|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://google.com/abc
localhost/.
localhost.
localhost/
http://stackoverflow.com/questions/ask
google.com
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s
https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/
https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something
https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)