import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\.org)((?:\\/kr\\/customer\\/account\\/forgotpassword\\/)(\\?.+)?)|((?:\\/partners\\/boeing\\/customer\\/account\\/forgotpassword\\/)(\\?.+)?)(?:(?= )|$)";
final String string = "http://google.com/abc\n"
+ "localhost/.\n"
+ "localhost.\n"
+ "localhost/\n"
+ "http://stackoverflow.com/questions/ask\n"
+ "google.com\n\n"
+ "https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984\n\n"
+ "https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/?camp=23984s\n\n"
+ "https://oncall3464-donate.d2.worldvision.org/kr/customer/account/forgotpassword/\n"
+ "https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/?camp=23453\n\n"
+ "https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/\n\n"
+ "https://oncall3464-donate.d2.worldvision.org/partners/boeing/customer/account/forgotpassword/something\n\n"
+ "https://oncall3464-donate.d2.worldvision.org/something/partners/boeing/customer/account/forgotpassword/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}