# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:\d{2}(,|$)/$1/g;t' <<< "12:00:00,11:30:00,10:30:00,10:00:00,09:30:00"