using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @":\d{2}(,|$)";
string substitution = @"$1";
string input = @"12:00:00,11:30:00,10:30:00,10:00:00,09:30:00";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}