const regex = /:\d{2}(,|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\d{2}(,|$)', 'g')
const str = `12:00:00,11:30:00,10:30:00,10:00:00,09:30:00`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);