re = /:\d{2}(,|$)/
str = '12:00:00,11:30:00,10:30:00,10:00:00,09:30:00'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result