// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":\d{2}(,|$)").unwrap();
let string = "12:00:00,11:30:00,10:30:00,10:00:00,09:30:00";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}