import Foundation
let pattern = #":\d{2}(,|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"12:00:00,11:30:00,10:30:00,10:00:00,09:30:00"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)