#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*"
Local $sString = "" & @CRLF & _
"http:lahunda.com/np" & @CRLF & _
"https:lahunda.com/" & @CRLF & _
"http:lam123.com/" & @CRLF & _
"http:abd123.com" & @CRLF & _
"https:kk12kk.com/prpp" & @CRLF & _
"https:asda23.comoerce/" & @CRLF & _
"" & @CRLF & _
"ppshttps:" & @CRLF & _
"hkttps:" & @CRLF & _
"hkps" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")