import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(http)(s?)\\:.\\N*.(\\D{3})\\/?(\\N?)*";
final String string = "\n"
+ "http:lahunda.com/np\n"
+ "https:lahunda.com/\n"
+ "http:lam123.com/\n"
+ "http:abd123.com\n"
+ "https:kk12kk.com/prpp\n"
+ "https:asda23.comoerce/\n\n"
+ "ppshttps:\n"
+ "hkttps:\n"
+ "hkps\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}