const regex = /^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http)(s?)\\:.\\N*.(\\D{3})\\\/?(\\N?)*', 'gm')
const str = `
http:lahunda.com/np
https:lahunda.com/
http:lam123.com/
http:abd123.com
https:kk12kk.com/prpp
https:asda23.comoerce/
ppshttps:
hkttps:
hkps
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}