use strict;
my $str = '
http:lahunda.com/np
https:lahunda.com/
http:lam123.com/
http:abd123.com
https:kk12kk.com/prpp
https:asda23.comoerce/
ppshttps:
hkttps:
hkps
';
my $regex = qr/^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}