re = /^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*/m
str = '
http:lahunda.com/np
https:lahunda.com/
http:lam123.com/
http:abd123.com
https:kk12kk.com/prpp
https:asda23.comoerce/
ppshttps:
hkttps:
hkps
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end