using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*";
string input = @"
http:lahunda.com/np
https:lahunda.com/
http:lam123.com/
http:abd123.com
https:kk12kk.com/prpp
https:asda23.comoerce/
ppshttps:
hkttps:
hkps
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}