package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http)(s?)\:.\N*.(\D{3})\/?(\N?)*`)
var str = `
http:lahunda.com/np
https:lahunda.com/
http:lam123.com/
http:abd123.com
https:kk12kk.com/prpp
https:asda23.comoerce/
ppshttps:
hkttps:
hkps
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}