# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/FLAGSHARE[\S\s]*?\d\s*\d\n//g;t' <<< "FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words...."