re = /FLAGSHARE[\S\s]*?\d\s*\d\n/
str = 'FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words....'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result