import re
regex = re.compile(r"FLAGSHARE[\S\s]*?\d\s*\d\n")
test_str = ("FLAGSHARE\n"
"xxxxxx\n"
"xxxxx, 1 2015\n\n"
"words....\n\n"
" FLAGSHARE\n"
" xxxxxx\n"
" xxxxx, 2 2015\n\n"
" words....\n\n"
" FLAGSHARE\n"
" xxxxxx\n"
" xxxxx, 3 2015\n\n"
" words....")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)