const regex = /FLAGSHARE[\S\s]*?\d\s*\d\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('FLAGSHARE[\\S\\s]*?\\d\\s*\\d\\n', 'g')
const str = `FLAGSHARE
xxxxxx
xxxxx, 1 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 2 2015
words....
FLAGSHARE
xxxxxx
xxxxx, 3 2015
words....`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);