import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "FLAGSHARE[\\S\\s]*?\\d\\s*\\d\\n";
final String string = "FLAGSHARE\n"
+ "xxxxxx\n"
+ "xxxxx, 1 2015\n\n"
+ "words....\n\n"
+ " FLAGSHARE\n"
+ " xxxxxx\n"
+ " xxxxx, 2 2015\n\n"
+ " words....\n\n"
+ " FLAGSHARE\n"
+ " xxxxxx\n"
+ " xxxxx, 3 2015\n\n"
+ " words....";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}