#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(\h*const\s+filename\s*=\s*).+"
Local $sString = "// blah blah blah" & @CRLF & _
"" & @CRLF & _
"const filename = ""; // it can be filename = ''; or filename = null; or filename = undefined; and so on" & @CRLF & _
"" & @CRLF & _
"// blah blah blah"
Local $sSubst = "$1"NEW VALUE";"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)