// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(\h*const\s+filename\s*=\s*).+").unwrap();
let string = "// blah blah blah
const filename = \"\"; // it can be filename = ''; or filename = null; or filename = undefined; and so on
// blah blah blah";
let substitution = "$1\"NEW VALUE\";";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}