package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^(\h*const\s+filename\s*=\s*).+`)
var str = `// blah blah blah
const filename = ""; // it can be filename = ''; or filename = null; or filename = undefined; and so on
// blah blah blah`
var substitution = "$1"NEW VALUE";"
fmt.Println(re.ReplaceAllString(str, substitution))
}