use strict;
my $str = '// blah blah blah
const filename = ""; // it can be filename = \'\'; or filename = null; or filename = undefined; and so on
// blah blah blah';
my $regex = qr/^(\h*const\s+filename\s*=\s*).+/imp;
my $subst = '$1"NEW VALUE";';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";