import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\h*const\\s+filename\\s*=\\s*).+";
final String string = "// blah blah blah\n\n"
+ "const filename = \"\"; // it can be filename = ''; or filename = null; or filename = undefined; and so on\n\n"
+ "// blah blah blah";
final String subst = "$1\"NEW VALUE\";";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}