re = /^(\h*const\s+filename\s*=\s*).+/im
str = '// blah blah blah
const filename = ""; // it can be filename = \'\'; or filename = null; or filename = undefined; and so on
// blah blah blah'
subst = '$1"NEW VALUE";'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result