# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\h*const\s+filename\s*=\s*).+"
test_str = ("// blah blah blah\n\n"
"const filename = \"\"; // it can be filename = ''; or filename = null; or filename = undefined; and so on\n\n"
"// blah blah blah")
subst = "$1\"NEW VALUE\";"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.