const regex = /^(\h*const\s+filename\s*=\s*).+/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\h*const\\s+filename\\s*=\\s*).+', 'igm')
const str = `// blah blah blah
const filename = ""; // it can be filename = ''; or filename = null; or filename = undefined; and so on
// blah blah blah`;
const subst = `$1"NEW VALUE";`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);