# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d)()(?=(\d{3})+(?!\d))/$1 $2/g;t' <<< "25
321
54500
78545515201"