#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d)()(?=(\d{3})+(?!\d))"
Local $sString = "25" & @CRLF & _
"321" & @CRLF & _
"54500" & @CRLF & _
"78545515201"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)